Google Flutter

Google Flutter: วิธีแก้ปัญหา CocoaPods installed but not working

เรื่องที่เกี่ยวข้อง - ,

สำหรับคนที่ใช้ macOS อาจจะเจอปัญหาตามด้านล่างนี้ ในการอัพเดตมาใช้ Flutter SDK เวอร์ชั่นล่าสุดนะครับ พลเองก็เจอเหมือนกัน

หากรัน flutter doctor จะเจอปัญหาดังนี้

[!] Xcode - develop for iOS and macOS (Xcode 11.4.1)
    ✗ CocoaPods installed but not working.
        You appear to have CocoaPods installed but it is not working.
        This can happen if the version of Ruby that CocoaPods was installed with is different from the one being used
        to invoke it.
        This can usually be fixed by re-installing CocoaPods. For more info, see
        https://github.com/flutter/flutter/issues/14293.
      To re-install CocoaPods, run:
        sudo gem install cocoapods

ปลุกปล้ำกับมันอยู่นานมาก โดยไล่ตาม StackOverflow 1, 2, 3 มาจบที่วิธีการแก้ด้านล่างนี้ครับ

อย่างแรกรันคำสั่ง 2 ตัวด้านล่างนี้ก่อน

sudo gem install -n /usr/local/bin cocoapods
brew unlink cocoapods && brew link cocoapods

จากนั้นให้รันคำสั่งนี้ปิดท้าย

rvmsudo gem install cocoapods

จากนั้นเช็ค ด้วย flutter doctor จะเห็นว่าข้อความเตือนหายไปแล้วจ้า

[✓] Xcode - develop for iOS and macOS (Xcode 11.4.1)

ติดตามวิธีแก้ปัญหาดีๆ แบบนี้ผ่านช่องทางต่อไปนี้ และเริ่มต้นเรียนรู้แบบเข้าใจง่ายด้านล่างครับ

คอร์สออนไลน์เริ่มต้นสร้าง Mobile App ด้วย Google Flutter

เหมาะผู้เริ่มต้น และนักพัฒนาเว็บ, เข้าใจง่าย, ใช้ได้จริง

สอบถาม หรือติดต่อจัดอบรมโทร 083-071-3373

เปิดอบรมสร้าง Cross Platform Mobile Application ด้วย Ionic Framework

เหมาะสำหรับคนทำเว็บ, เริ่มต้น JavaScript ES6 และ Angular เข้าใจง่าย, ใช้ได้จริง

สอบถาม หรือติดต่อจัดอบรมโทร 083-071-3373

โปรหน้าฝน! เรียนรอบสด รับคอร์สออนไลน์มูลค่ากว่า 5800 บาทฟรี!

Loading Facebook Comments ...
Menu